SOFA 2.0 Editor - GUI Repository Designer for Eclipse

NEWS

2007-06-10

SOFA 2.0 repository editor v. 1.3.0 released. Changes »

2007-02-10

SOFA 2.0 repository editor v. 1.0.149 released.

2006-10-21

Work on the plug-in is started. History »

MANUALS

Compiling and installation

User's manual

Usage scenarios

Developer's manual

UML diagrams

Java docs

Author MaViNes (c)

ARTICLES

OSGI Framework

Eclipse plugin basics

RCP basics

SWT draw basics

jFace tips

SWT Linux/Windows differences

Author MaViNes (c)

<< Previous | Table of contents | Next >>

Chapter 2. System requirements and installation

The plug-in requires Eclipse IDE 3.2 or higher and Java 6.0 installed. Also it is required to install and run the Sofa 2.0 repository server. For more information please refer to http://sofa.objectweb.org/. Optional requirement is Apache Ant. No other plug-ins are required in order to install and run the sofaclipse plug-in.

The installation can be done in several ways: the current version of the plug-in can be downloaded as a local copy and installed as a local site from the Help -> Software Updates -> Find and install wizard. Also it can be installed using the same wizard but from the remote site (http://dsrg.mff.cuni.cz/~nesen/eclipse/update/). And finally it can be compiled and installed from source.

For more information about the installation procedure please refer to the installation guide which should be supplied with this manual or to the online installation guide which is available from http://dsrg.mff.cuni.cz/~nesen/eclipse/.



<< Previous | Table of contents | Next >>

Learn More